Author Topic: Firefox doesn't display favourites  (Read 601 times)

Offline Roobarb

  • RootsChat Aristocrat
  • ******
  • Posts: 2,311
  • Looking for that elusive branch!
    • View Profile
Firefox doesn't display favourites
« on: Monday 02 August 21 18:04 BST (UK) »
I've recently found that my Firefox browser on my laptop no longer displays my most visited bookmarks, they used to be along the top of the screen under the website address. I have the bookmarks marked as Always Show, although I have tried to unticked that option to see if it has any effect but it doesn't untick or make any difference! I can get my bookmarks toolbar to appear as a sidebar.
Not only that, clicking on the hamburger at the top right doesn't do anything at all and the cross to close down the browser isn't visible until I hover over it and even then it only shows as a red square. The option to restore down the screen is similar, only shows as a grey square when I hover over it.
I'm attaching a screenshot of how the top of the screen was when I opened the browser, nothing has changed now except that I have a couple of tabs open.

Can anyone please help? I'm pulling my hair out with this!
Bell, Salter, Street - Devon, Middlesbrough.
Lickess- North Yorkshire, Middlesbrough.
Etherington - North Yorks and Durham.
Barker- North Yorks
Crooks- Durham
Forster- North Yorks/Durham
Newsam, Pattison, Proud - North Yorks.
Timothy, Griffiths, Jones - South Wales

Offline MarionE2

  • RootsChat Extra
  • **
  • Posts: 33
  • Census information Crown Copyright, from www.nationalarchives.gov.uk
    • View Profile
Re: Firefox doesn't display favourites
« Reply #1 on: Monday 02 August 21 19:20 BST (UK) »
Hi Roobarb,

If you click on the three lines at the top right of the Firefox page, scroll down the options that appear and select More Tools. From there select Customize Toolbar.

At the bottom left there are four options. Clicking on the word Toolbar, you have the option to select Menu Bar. Click on that.  From there you can choose how you want your Favourites displayed - in the library symbol or on the address bar with the bookmark symbol. Just left click on the choice you want and drag it up to the right side of the address bar. If you decide you don't want it there and prefer to find your sites by looking in Bookmarks on the menu bar, just right click on the symbol you added to the right of the address bar, and select delete.

Hope this helps. Marion

Offline arthurk

  • RootsChat Marquessate
  • *******
  • Posts: 3,933
    • View Profile
Re: Firefox doesn't display favourites
« Reply #2 on: Monday 02 August 21 19:35 BST (UK) »
From your screenshot, it looks as though your bookmarks toolbar is there, but it's empty. Does that sound like what you're getting? And if you view your bookmarks in a sidebar, are they in the Bookmarks Toolbar folder or one of the others?

I'm not sure I'm going to be able to give you the answer, but for comparison I've attached clips of my menus/settings, and I do have the toolbar showing and filled with bookmarks:

The Menu one has Always Show ticked (as you said yours is)
The Customise one shows what the toolbar looks like in the Customise window, with the toolbar items showing at the left hand end
The Library one shows the Bookmarks Toolbar folder in context, and I can open it up to show the subfolders and bookmarks that I normally have showing.

All I can suggest at present is that you compare your settings to mine, and make sure that the Bookmarks Toolbar folder (in the Library or sidebar) contains the bookmarks you want to see. I hope that helps........
Researching among others:
Bartle, Bilton, Bingley, Campbell, Craven, Emmott, Harcourt, Hirst, Kellet(t), Kennedy,
Meaburn, Mennile/Meynell, Metcalf(e), Palliser, Robinson, Rutter, Shipley, Stow, Wilkinson

Census information is Crown Copyright, from www.nationalarchives.gov.uk


Offline Roobarb

  • RootsChat Aristocrat
  • ******
  • Posts: 2,311
  • Looking for that elusive branch!
    • View Profile
Re: Firefox doesn't display favourites
« Reply #3 on: Monday 02 August 21 20:20 BST (UK) »
Thanks for the replies.

Marion, clicking on the three lines  ( the hamburger) doesn't work so unfortunately I'm unable to follow the further steps from there.

Arthurk, I can access the bookmarks from the sidebar or library, it's just that the most used ones don't show in a horizontal row below the current website address. Your picture seems to show them in a similar way to how mine used to be.

It seems strange that not only this has disappeared but that the other things at the top of the screen don't work properly. The home page used to be Google but even that isn't there now. I can usually manage to sort things like this out but I must admit this has me baffled.



Bell, Salter, Street - Devon, Middlesbrough.
Lickess- North Yorkshire, Middlesbrough.
Etherington - North Yorks and Durham.
Barker- North Yorks
Crooks- Durham
Forster- North Yorks/Durham
Newsam, Pattison, Proud - North Yorks.
Timothy, Griffiths, Jones - South Wales

Offline arthurk

  • RootsChat Marquessate
  • *******
  • Posts: 3,933
    • View Profile
Re: Firefox doesn't display favourites
« Reply #4 on: Monday 02 August 21 20:36 BST (UK) »
I can't think what else to suggest, but if anything else does come to me I'll post again (not before tomorrow).

Meanwhile, are the bookmarks you want on the toolbar still in the Bookmarks Toolbar folder (which you should be able to access via the library or sidebar)?
Researching among others:
Bartle, Bilton, Bingley, Campbell, Craven, Emmott, Harcourt, Hirst, Kellet(t), Kennedy,
Meaburn, Mennile/Meynell, Metcalf(e), Palliser, Robinson, Rutter, Shipley, Stow, Wilkinson

Census information is Crown Copyright, from www.nationalarchives.gov.uk

Offline Erato

  • RootsChat Marquessate
  • *******
  • Posts: 5,819
  • Walker Home for Missionary Children
    • View Profile
Re: Firefox doesn't display favourites
« Reply #5 on: Monday 02 August 21 20:45 BST (UK) »
Wiltshire:  Banks, Taylor
Somerset:  Duddridge, Richards, Barnard, Pillinger
Gloucestershire:  Barnard, Marsh, Crossman
Bristol:  Banks, Duddridge, Barnard
Down:  Ennis, McGee
Wicklow:  Chapman, Pepper
Wigtownshire:  Logan, Conning
Wisconsin:  Ennis, Chapman, Logan, Ware
Maine:  Ware, Mitchell, Tarr, Davis

Offline MarionE2

  • RootsChat Extra
  • **
  • Posts: 33
  • Census information Crown Copyright, from www.nationalarchives.gov.uk
    • View Profile
Re: Firefox doesn't display favourites
« Reply #6 on: Monday 02 August 21 20:52 BST (UK) »
Roobarb,

Perhaps this is what you'd like:

On the menu bar click on Tools. Go down the menu that opens and left click on Settings. A page opens that will show, on the left side, General, Home, Search etc.  Click on Home.  To the right of these options, there should be one called Firefox Home Content. If there is not a check mark beside Shortcuts, click in the empty box so that one appears.  Close Firefox and then re-open it. Hopefully this is it. 

Marion

Offline Roobarb

  • RootsChat Aristocrat
  • ******
  • Posts: 2,311
  • Looking for that elusive branch!
    • View Profile
Re: Firefox doesn't display favourites
« Reply #7 on: Tuesday 03 August 21 22:57 BST (UK) »
Arthur, yes the bookmarks are still there in the folder although not as they appeared before, ie I had a number of folders such as Family History with bookmarks for TNA etc. The folders don't appear to be there now.

Marion, I haven't been able to get back onto the laptop yet, will check that out when I do, thanks.

Erato, I'm hoping it doesn't come to that but fear it might. I must have done that previously as there's a folder on my desktop called Old Firefox Data, I think it was put there automatically but can't remember the circumstances.
Bell, Salter, Street - Devon, Middlesbrough.
Lickess- North Yorkshire, Middlesbrough.
Etherington - North Yorks and Durham.
Barker- North Yorks
Crooks- Durham
Forster- North Yorks/Durham
Newsam, Pattison, Proud - North Yorks.
Timothy, Griffiths, Jones - South Wales

Offline Roobarb

  • RootsChat Aristocrat
  • ******
  • Posts: 2,311
  • Looking for that elusive branch!
    • View Profile
Re: Firefox doesn't display favourites
« Reply #8 on: Wednesday 04 August 21 12:26 BST (UK) »
Marion,  I've had a look at the settings as suggested,  the options in Home don't show Firefox Home Content. There's an option to the right of Home to Restore Defaults (have been tempted to try this but will wait and see what you say!)
Under that it has a heading New Windows and Tabs. The options within that for Homepage and new windows are Firefox Home (Default), Custom URLs, Blank page.
Bell, Salter, Street - Devon, Middlesbrough.
Lickess- North Yorkshire, Middlesbrough.
Etherington - North Yorks and Durham.
Barker- North Yorks
Crooks- Durham
Forster- North Yorks/Durham
Newsam, Pattison, Proud - North Yorks.
Timothy, Griffiths, Jones - South Wales